npm ERR! git@github.com: Permission denied (publickey)

Problem

NPM install can't connect to the github to get the required mobidonia/firebase-paginator module. 

Cause

We don't know. Maybe TLS version, github changes or node version

Solution

Remove node_modules folder

remove package-lock.json file

Edit packagage.json file

-- IMPORTANT --

Replace

"firebase-paginator": "git....",

with

"mobidonia-firebase-paginator": "1.1.1",

Then

Edit src/containers/Fireadmin.js

replace

import FirebasePaginator from "firebase-paginator"

with

import FirebasePaginator from "mobidonia-firebase-paginator" 

run npm install

run npm start



So package.json should look like this 

https://gist.github.com/dimovdaniel/9ad97d9e7b6f7a8124199433b77758e1